活动:限时7折!去购买
请问一下狼哥,我在安装swoole 时 提示:在给定的目录下,LIBDIR必须使用libtool,难道是需要安装扩展库?
7 152 2018-01-17

图书馆已安装:/root/swoole-1.9.6 /模块 如果您碰巧想要链接到已安装的库。 在给定的目录下,LIBDIR必须使用libtool,并且。 指定库的完整路径名,或使用' -LLIBDIR' 在连接过程中标记,并至少执行下列操作之一: -将LIBDIR添加到“LD_LIBRARY_PATH”环境变量。在执行期间-将LIBDIR添加到“LD_RUN_PATH”环境变量。在连接-使用' - wl,- rpath - wl,LIBDIR' linker标志。 -让系统管理员将LIBDIR添加到' /etc/ lsd .conf' 有关共享库的任何操作系统文档。

  • 7 个回答
  • 可以把具体的报错信息贴一下,不用翻译。

  • Libraries have been installed in: /root/swoole-1.9.6/modules

    If you ever happen to want to link against installed libraries in a given directory, LIBDIR, you must either use libtool, and specify the full pathname of the library, or use the `-LLIBDIR' flag during linking and do at least one of the following:

    • add LIBDIR to the `LD_LIBRARY_PATH' environment variable during execution
    • add LIBDIR to the `LD_RUN_PATH' environment variable during linking
    • use the `-Wl,--rpath -Wl,LIBDIR' linker flag
    • have your system administrator add LIBDIR to `/etc/ld.so.conf' 就是这个提示

  • 额,你这没发现有问题呀,继续make install 试试

  • 这是什么意思啦 [root@localhost swoole-1.9.6]# make install Installing shared extensions: /usr/local/php/lib/php/extensions/no-debug-non-zts-20121212/

  • 难道是把 /usr/local/php/lib/php/extensions/no-debug-non-zts-20121212/ swwoole.so 添加到 php .ini ?

  • 建议找一篇详细的安装swoole的文章看看。

  • 哦哦

登录 去赚佣金